Anúncios
Fedora 13

Configurando Interfaces e roteamento entre dois roteadores Cisco

Para esse exemplo, usarei o Packet Tracer (download aqui). Esse software foi desenvolvido pela própria Cisco para que os interessados pudessem fazer treinamentos e experimentos em seus equipamentos. Esse software é altamente recomendado para os interessados em entender conceitos de roteamento além de colocar em prática projetos teóricos ou mesmo testar futuras configurações em roteadores reais.

 Devemos, nesse primeiro exercício, criar a seguinte ligação de rede:

 

Para começar, com um projeto novo no Packet Tracer, vou adicionar um Router modelo 2620XM.

 

Feito isso, vou clicar sobre o roteador que foi colocado na Área de Trabalho do PT e vou clicar 1 vez sobre ele. Ao fazer isso, será aberta uma tela para adicionarmos módulos nesse roteador bem como fazer as configurações necessárias.

Para interligar os dois roteadores, vou usar a interface serial do roteador. Podemos verificar que esse roteador não possui nenhuma interface serial, então vamos adicionar um módulo de interface serial. Para fazer isso, primeiro devemos desligar o roteador.

 

Depois vamos selecionar o módulo a ser adicionado no roteador. Nesse caso, vamos usar o módulo NM-4A/S. Clicamos sobre ele do lado direito (01) nessa tela, e o módulo será exibido no canto direito inferior. Clicamos então sobre ele (02) e arrastamos até o “slot” do roteador. Feito isso, ligamos (03).

 

Caso queria acompanhar o processo de “start” da IOS, é só clicar na guia CLI que o processo será exibido.

 

Como é um roteador sem configuração nenhuma, depois da IOS ser totalmente carregada, será exibida a seguinte mensagem:  “Continue with configuration dialog? [yes/no]:” Vamos optar por não usar esse assistente pois usaremos a configuração manual. Então digite no e pressione “Enter”.

Depois pressione “Enter” novamente, conforme solicitado pelo Router.

Lembrando que o primeiro acesso é feito no modo usuário, devemos acessar o modo privilegiado para depois acessar os módulos das interfaces para começarmos a configuração em si. Então vamos digitar:

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#

Vamos começar a configurar pela Interface Ethernet 0/0 ou seja, a interface que vai ligado ao Hub ou Switch. Para isso vamos digitar:

Router(config)#interface fastethernet 0/0
Router(config-if)#
 
Reparem que ele sinaliza o módulo de configuração de interface com as letras “if” depois de “config”.

Vamos adicionar então o IP e a máscara conforme está na imagem acima e claro, ativar a interface:

Router(config-if)#ip address 192.168.0.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config-if)#

Agora vamos configurar a Interface Serial 1/0: (lembrando que precisamos sair do módulo de configuração da Interface Ethernet primeiro)

Router(config-if)#exit
Router(config)#interface serial 1/0
Router(config-if)#

Agora vamos configurar IP e Mascara (conforme a imagem), ativar a interface e setar o clock rate de 56000.

Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#clock rate 56000
%LINK-5-CHANGED: Interface Serial1/0, changed state to down
Router(config-if)#

Agora vamos a configuração do segundo roteador, alterando apenas os endereços IP conforme a imagem. (Lembrem-se de adicionar o módulo de interfaces seriais).

Como já expliquei passo a passo o roteador anterior, esse segundo roteador, vou apenas colocar os comandos para seguirem caso tenham alguma dúvida, mas não vou comentá-los.

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
 
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface serial 1/0
Router(config-if)#ip address 192.168.1.2 255.255.255.0
Router(config-if)#no shutdown
 
%LINK-5-CHANGED: Interface Serial1/0, changed state to down
Router(config-if)#

Depois da configuração dos dois Roteadores, vamos adicionar os demais itens das nossas redes: 1 Hub para cada rede, bem como uma máquina para cada rede também.

 

Feito isso, vou agora fazer as ligações entre os roteadores e os Hubs de locais de sua rede, e depois a interligação física dos dois roteadores.

Primeiro vou interligar os Hubs às suas respectivas máquinas via interface de rede via cabo UTP (no PT chamado de Copper Straight-Through) e posteriormente ligar os Hubs aos Roteadores da sua Rede também via cabo UTP.

 

Agora vou fazer a interligação dos dois Roteadores usando as interfaces Seriais. Para isso, logicamente, vou usar o cabo serial. Às vezes o pessoal tem dúvidas quanto a qual dos dois cabos Seriais se deve usar. Lembrem-se:

- DCE: C=Comunication ou seja, equipamento de comunicação (roteador, switch)

- DTE: T=Terminal ou seja, computador, servidor, etc.

Então nesse caso usaremos o DCE. Selecione então esse cabo, clique sobre o Router 1 e depois sobre o Router2 nos dois casos, selecionando a Interface Serial 1/0 (que foi a indicada no desenho e configurada).

 

Depois da interligação física, é hora de indicar o protocolo de roteamento a ser usado e configurá-lo.

No Router da Rede1, vou executar os comando:

Router(config)#router rip
Router(config-router)#network 192.168.0.0
Router(config-router)#network 192.168.1.0

Essa sequência de comandos indica que vou usar o protocolo RIP e as redes que estão ligadas diretamente à esse roteador são: 192.168.0.0 e 192.168.1.0 que são as duas redes que estão configuradas nas duas interfaces em uso no Router 1.

Devemos executar a mesma sequência de comandos no Router2, alterando lógico as redes a serem divulgadas: devemos informar as duas redes que estão configuradas nas duas interfaces do roteador.

Depois de divulgadas as redes nos dois roteadores, devemos configurar os Endereços IP das interfaces de rede das máquinas das redes.

Para isso clicamos em cima do computador PC1-Rede1, na tela que abrir, clicar na guia Desktop e clicar em IP Configuration. Configurar então o endereço ip da máquina, lembrando que o gateway de cada máquina deve ser o ip da interface de rede do seu devido roteador.

Depois de configurar os dois computadores, clique em “Command Prompt” e faça testes de ping, pingando de uma máquina de uma rede, até a outra máquina da outra rede.

Dúvidas, estou a disposição.

Até mais!

Comentários (23)
  • eduardo  - Configurando Interfaces e roteamento entre dois ro

    minha rede esta da mesma forma que esse exemplo que vc colocou, mas ainda falta um comando que fara as maquinas se comunicarem, o pc 1 acessa o router 1 e o pc 2 acessa o pc 2, mas quando se tenta com que o pc 1 acesse o pc 2 fica "FAILED" e não SUCCESSFUL...

  • Renato [censurado]nha

    Amigo,

    veja se não faltou o clock rate 56000 no router2

  • Paulo  - re: Configurando Interfaces e roteamento entre doi
    eduardo Escreveu:
    minha rede esta da mesma forma que esse exemplo que vc colocou, mas ainda falta um comando que fara as maquinas se comunicarem, o pc 1 acessa o router 1 e o pc 2 acessa o pc 2, mas quando se tenta com que o pc 1 acesse o pc 2 fica "FAILED" e não SUCCESSFUL...

    Para o pc1 comunicar com o 2 , é necessario vc criar uma rota estática em cada router. No router 1 , crie a seguinte rota

    Router(config)#ip route 192.168.2.0 255.255.255.0 192.168.1.0

    No router 2

    Router(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.0

  • Marcos Neto  - dois

    Qual o ip que posso colocar para os meu PCS e qual o gateway?? quando coloquei o gateway do roteador o ping deu 100% de perda do PC1 para PC2.
    Mas o PC acessa o router1 e o PC2 acessa o router2.

  • wagner  - excelente material

    parabens, material de otima qualidade.

  • wagner  - marcos neto

    o gateway vai ser o ip do roteador ao qual o pc1 e 2 estao ligados. quanto aos ips dos pc's. o pc ligado ao gateway 192.168.1.1 pode ficar com o ip 192.168.1.2 e o pc liagado ao gateway 192.168.2.1 pode ficar com ip 192.168.2.2. nao esqueça que as mascaras de rede devem ser 255.255.255.0. abraço

  • Wesley Silvério  - O meu ex. pingou tudo direitinho

    Amigo Paulo, nao entendi vc disse respondendo a duvida do Eduardo que necessita traçar uma rota estatica em cada router. tudo bem mas eu fiz como vc ensinou no seu ex. e pingou tudo direitinho. me explique melhor sobre esta configuração de rota estatica entre roteadores. quando necessita e o que é de verdade. ficarei muito grato.. amigo. e aproveitando gostaria de te dar os PARABENS. sua explicação ai foi 100000000... aprendi muito.. valeu..
    aguardo resposta..

  • Gabriel Cesar  - Fico Feliz!

    Fico feliz em saber que ainda possamos contar com pessoas como você que tem o dom de compartilhar a informação obtida, bem como a paciência e boa vontade em ajudar. Sua aula foi excepcional. Obrigado!

  • Alexandre  - Muito Bom

    Sou aluno de CC da cidade de Ribeirão Preto e gostaria de agradecer seu tutorial me ajudou muito.e como disse o comentário acima obrigado por vc ter esse dom de compartilhar!!!

    Abraços

  • Alessandro  - Protocolo OSPF

    E neste mesmo exemplo usando o protocolo OSPF, como seria?

  • Fernando  - Obrigado

    Cara, ajudou muito!
    Muito obrigado!!

  • Fabio  - É isso aí amigo!

    Os maiores cientistas, pensadores e etc. deixaram suas obras para que pudessemos estudá-las, mas você caro amigo, compartilhou aquilo que é de muita importância para nós o conhecimento, obrigado e continue assim. abraços

  • Eduardo  - Fantastico

    :D Fantastico me ajudou muito fico agradecido

  • alan  - erro

    amigo qd digito o comando
    interface serial 1/0
    ele da erro
    % Invalid input detected at '^' marker.

    vc sabe pq?

  • Douglas

    PARABENS MUITO BOM, OBRIGADO

  • Anônimo

    Olá,sou estudande de um [censurado]rso técnico achei muito enteressante a sua esplicação, porém não entendi o que você quis dizer conforme a descrição abaixo.
    Devemos exe[censurado]tar a mesma sequência de comandos no Router2, alterando lógico as redes a serem divulgadas: devemos informar as duas redes que estão configuradas nas duas interfaces do roteador.

    Depois de divulgadas as redes nos dois roteadores, devemos configurar os Endereços IP das interfaces de rede das máquinas das redes.

    Poderia me explicar como fazer?

  • Diorginis  - Excelente

    Obrigado

  • paulo  - material de boa qualidade

    valeu ta melhor que meu professor....

  • Rodrigues Lopes  - Pesso para me enviar a configuracao do ruter cisco

    com relacao a configuracao do ruter, penso que vai ajudar os IT a fazer o seu trabalho no terreno, e posetivo envie mais vezes.

  • wagner

    valeu,
    obrigado. :D

  • fabio luiz  - valeu....

    obrigado pela aula :D
    era sobre a questao do gateway...mas já foi respondido...valeuuuuuuuuuuuu

  • Andre Lima  - Rota Estatica???

    Só queria saber qm falo q tm que usar rota estatica neste lab???

    Obg...rsrs
    :0

  • Joao Fernando  - Interligando roteadores

    Eu fiz uma rede parecida mas eu uso 3 roteadores..

    se eu conecto os roteadores com cabo serial a informação trafega normal..

    mas se eu conecto os roteadores com cabo RJ trançado a informação nao trafega...

    Porque?

    abraços

Escrever um comentário
Seus Detalhes:
Comentário:
[b] [i] [u] [url] [quote] [code] [img]   
:D:angry::angry-red::evil::idea::love::x:no-comments::ooo::pirate::?::(:sleep::););)):0
Security
Por favor coloque o código anti-spam que você lê na imagem.
Usuários Registrados